Ziller Electric Inc | Interactive Generac Generator Forum  

Go Back   Ziller Electric Inc | Interactive Generac Generator Forum > Generac Generator Tech Talk > Guardian Portable Gasoline Generators

Guardian Portable Gasoline Generators Questions, Answers, and Information About Gasoline Powered Portable Guardian Generators

Reply
 
Thread Tools Search this Thread Display Modes
Old April 11th, 2012   #1
mikekm5uk1
Junior Member
 
Join Date: Apr 2012
Posts: 13
Smile 15kW gasoline Guardian portable starting problem

Hi, new guy here! My 15K gasoline unit with 10 hrs on it, won't run. It will start right up for a second, then die. The carb jets are clean. The FSS is operating (plunger moves) I dont have an hourmeter, so i will check some recommendations by Jogginguy, maybe apply 12 volts to keep the FSS open after releasing the starter circuit.
Any help is, of course, appreciated.
tnx, mike KM5UK
mikekm5uk1 is offline   Reply With Quote
Old April 11th, 2012   #2
SkipD
Moderator
 
SkipD's Avatar
 
Join Date: May 2008
Location: Southeastern Wisconsin
Posts: 2,279
Default

It would be very helpful if you'd post the model number and approximate production date so the folks here can know what machine you have.
__________________
Skip Douglas
SkipD is offline   Reply With Quote
Old April 11th, 2012   #3
mikekm5uk1
Junior Member
 
Join Date: Apr 2012
Posts: 13
Default Generac Guardian Ultra Source Gasoline Portable 15K

Hi Skip and tnx for answering. The model is 004582-2, approx 2008 yr model.
I can make it continue to run by jumping from battery to the FSS, keeping it open for fuel supply. Wire 14 from FSS to R1 is good also. Earlier today, I ran it 30 minutes by reconnecting the FSS solenoid for factory normal ops. Then it shut down again, and I could only run it by re-installing the jumper to 12v supply.. so its intermittent, do you think it could be the run-start-stop switch?
The unit has 10 hours on it at most, I start it monthly, then run it dry.
tnx again,
Mike KM5UK
mikekm5uk1 is offline   Reply With Quote
Old March 25th, 2013   #4
DennyL
Junior Member
 
Join Date: Mar 2013
Posts: 4
Angry 004582-2 starting problem

Mike,
I have been having the same problem with my unit (purchased in 2007 - only about 100 hours on it now). I changed the start-run-stop switch (SW1) to no avail, then downloaded the diagnostic manual and troubleshot down to what I thought was a failed governor control circuit board. Changed the board ($241) and it started and ran fine several times that same day. Two weeks later, I tried to start it again and it refused. Intermittent gremlin... Did you ever solve your problem?
Denny
DennyL is offline   Reply With Quote
Old August 16th, 2013   #5
mikekm5uk1
Junior Member
 
Join Date: Apr 2012
Posts: 13
Default

my unit has a low oil pressure switch, and the diag manual mentions that low oil level will shut it down.. I dont find a low oil level sensor, and my oil pressure switch checks out OK..Did your gov circuit board go out again, or do you now think that the original was good, and u changed it out unnecessarily? I hate to start changing out$241 parts if I dont have to.
thanks
mikekm5uk1 is offline   Reply With Quote
Old August 16th, 2013   #6
hoghead
Senior Member
 
Join Date: Dec 2008
Location: southside va
Posts: 307
Default

It is could be that the oil pressure switch is doing its job. I had a unit that had a non GENERAC oil filter. It would run for 10 min or 5 hours and just stop. Put a oil pressure gauge on it and saw it drop to 0. It was very intermittent and very time consuming to find the problem. I changed out the oil filter and everything was fine.
hoghead is offline   Reply With Quote
Old August 16th, 2013   #7
DennyL
Junior Member
 
Join Date: Mar 2013
Posts: 4
Default Bad relay

Guys - I sent a private message to mike on this, but want others to know that my problem turned out to be an intermittent start/stop relay (SSR). I checked it again after buying multiple parts, including a new carburetor after cracking the bowl on mine when reassembling it after cleaning, while repeating steps in the troubleshooting procedure that I had done before. This relay eventually failed consistently enough for me to find the problem. I think the part cost about $30, but I spent hundreds getting to the fix. Denny
__________________
Denny
DennyL is offline   Reply With Quote
Old August 16th, 2013   #8
Canada_Guy
Senior Member
 
Join Date: Oct 2009
Location: Vancouver Island, BC, Canada
Posts: 621
Default

DennyL: On the bright side, now you have some spare parts that might get you out of a jam someday.
__________________
Homeowner with 14kW air cooled Model 5612, Propane. Installed 9/2009
Canada_Guy is offline   Reply With Quote
Old January 24th, 2014   #9
mikekm5uk1
Junior Member
 
Join Date: Apr 2012
Posts: 13
Default

i decided to clean the carb, since it still won't run.. i removed the threaded jets, then used air to remove the inner jets.. Now, i dont know how to orient them, since the inner jets will fit either way..its a Dekni 2 barrel carb. #0F9035.. i cant find any exploded views for re-assembly. It still has about 10 hours total on it, wont start 2 days in a row.
Thanks for any help.
mikekm5uk1 is offline   Reply With Quote
Old January 30th, 2014   #10
mikekm5uk1
Junior Member
 
Join Date: Apr 2012
Posts: 13
Default

Denny,, i just read where u cracked the bowl i came close to doing that also, putting my jets in incorrectly after cleaning.. If the threaded jet is not flush in the socket, and it sticks out about 1/32", the bowl wont fit.. but u probably found that out by now.. i should be getting my SSR switch this week, to see if that fixes it.. i sure hope so, i have worked on it about 40 hours, and it has ran maybe 12 by now since the day it was new in 2008. mannnnnn
mikekm5uk1 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:32 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1985-2010 Ziller Electric Inc
Ziller Electric Inc is not representing Generac Power Systems Inc