Ziller Electric Inc | Interactive Generac Generator Forum  

Go Back   Ziller Electric Inc | Interactive Generac Generator Forum > Generac Generator Tech Talk > Generac Air Cooled Generators

Generac Air Cooled Generators Troubleshooting Questions, Answers, and Information About Air Cooled Guardian Generators

Reply
 
Thread Tools Search this Thread Display Modes
Old March 21st, 2010   #1
rogpike
Member
 
Join Date: Feb 2009
Posts: 36
Default "Inspect battery" warning message

Guardian 5744 Natural Gas

Installed one year ago 3/20/09.

The screen says "inspect battery".

I looked (inspected) at it and it looked fine. What causes this to come on? It will start fine but the warning is there. Any thoughts?
rogpike is offline   Reply With Quote
Old March 21st, 2010   #2
rogpike
Member
 
Join Date: Feb 2009
Posts: 36
Default Never Mind

I did a search and found out that it is a reminder to inspect the water level in the battery and the message can be cleared by pressing enter.

Here is the link to the thread.

http://zillerelectric.com/forums/sho...nspect+battery
rogpike is offline   Reply With Quote
Old March 22nd, 2010   #3
Kelly Myers
Administrator
 
Kelly Myers's Avatar
 
Join Date: Jan 2007
Posts: 1,053
Default

It's simply a reminder to literally "check the battery" and charging system. If it's ok, you can simply reset it.
__________________
Kelly Myers
Ziller Electric Inc.
http://zillerelectric.com
1-888-2-ZILLER
Kelly Myers is offline   Reply With Quote
Old June 23rd, 2010   #4
austinmc
Junior Member
 
Join Date: Jun 2010
Posts: 4
Default

I am getting this message everyday for 3 days straight and I have had my 20 kw generator for 5 days. I clear it each day and it comes back the next day.
austinmc is offline   Reply With Quote
Old June 24th, 2010   #5
austinmc
Junior Member
 
Join Date: Jun 2010
Posts: 4
Default

Talked to Generac Technical support today. They advised to reset the maintenance warnings on the lcd panel. I will post back on how this works.
austinmc is offline   Reply With Quote
Old June 25th, 2010   #6
austinmc
Junior Member
 
Join Date: Jun 2010
Posts: 4
Default

That didn't fix it, back to the drawing board.
austinmc is offline   Reply With Quote
Old June 28th, 2010   #7
Kelly Myers
Administrator
 
Kelly Myers's Avatar
 
Join Date: Jan 2007
Posts: 1,053
Default

Quote:
Originally Posted by austinmc View Post
That didn't fix it, back to the drawing board.
Hi Austin. Are you sure that you did it right? It is odd how they programmed the board. Going from memory you need to scroll to "RESET MAINT" and then hit enter, then click right and it will say "YES" then press enter again. It doesn't give you any confirmation that it reset it.
__________________
Kelly Myers
Ziller Electric Inc.
http://zillerelectric.com
1-888-2-ZILLER
Kelly Myers is offline   Reply With Quote
Old June 30th, 2010   #8
austinmc
Junior Member
 
Join Date: Jun 2010
Posts: 4
Default

Well it has gone away, for the last 5 days now. The last time I just pushed "ESC". Seems to have resolved. Thanks Kelly for your suggestion.
austinmc is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:16 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1985-2010 Ziller Electric Inc
Ziller Electric Inc is not representing Generac Power Systems Inc